>  Docs Center  >  Using ENVI  >  Getting Started with ENVI
ENVI

Getting Started with ENVI

Getting Started With ENVI

Getting Started with ENVI Tutorial

ENVI® is the premier image analysis software used by GIS professionals, remote sensing scientists, and image analysts. ENVI allows you to extract meaningful information from imagery to make better decisions. ENVI can be deployed and accessed from the desktop and in the cloud. It can also be customized through an IDL-based application programming interface (API) to meet specific project requirements.

See the following sections:

How to Start ENVI


Start ENVI as follows:

  • Windows: From the Windows Start menu, select ENVI x.x.x > ENVI x.x.x (64-bit), where x.x.x is the version number.
  • Linux: Type envi_rt at the shell prompt.
  • Macintosh: In the Finder window, go to the ENVI installation directory and double-click ENVI x.x.

Display the ENVI Help as follows:

  • Windows: From the Windows Start menu, select ENVI x.x.x > ENVI x.x.x Help or ENVI x.x.x > IDL x.x.x and ENVI x.x.x Help.
  • Linux:  Type envihelp at the shell prompt.
  • Macintosh: In the Finder window, go the ENVI installation directory and double-click ENVI x.x Help.

What You Can Do in ENVI


If you are new to ENVI, this section describes some of its most popular tools based on specific analysis goals. This is not a complete list of all of the things you can do in ENVI but rather some suggested starting points for common applications in remote sensing.

Tip: Most of ENVI's data processing tools are available in the Toolbox, located on the right side of the application. Options for viewing data and plots are provided in the ENVI menu bar. For a full list of tools, see the Table of Contents in this help. Even more tools are available by using the Run Task tool.

Read Satellite Image Formats

Local files

Use the File > Open menu option to open most image formats as well as LiDAR point cloud data. See the list of supported file types. Use the Full Motion Video tool to play video files. Use the Dataset Browser to open scientific data formats such as HDF and NetCDF.

Online data

The Download Web Data menu option lets you download remote sensing data from popular data portals and open the data directly in ENVI.

You can also download, open, and display OpenStreetMap® vectors within ENVI.

Use the Remote Connection Manager to access data from remote services such as OGC WMS and WCS, IAS, JPIP, ArcGIS geodatabases, and ArcGIS image services.

Visualize and Explore Images

The Data Manager lets you view individual bands of imagery or display different band combinations in the Image window. You can also animate through bands of an image, which is particularly helpful with hyperspectral images. See the Display Tools topic to learn about different tools for navigating and visualizing images.

To change the background color of a view, right-click on the View layer in the Layer Manager and select Change Background Color. Changing the color to something other than the default value of white can be helpful in separating background pixels from clouds and other highly saturated features.

To explore images of 3D terrain, you can use the Topographic Shading tool to create colored representations of digital elevation models (DEMs) and topographic features such as slope, aspect, and shaded relief.

Fix and Prepare Images for Analysis

Calibrate

The Radiometric Calibration tool can calibrate images to radiance or top-of-atmosphere reflectance. This removes the effects of scattered and emitted radiation by the atmosphere and makes the pixel data easier to interpret. If you have more than one image, calibration ensures that the pixel data are in the same physical units across all of the images.

Remove haze and clouds

The QUick Atmospheric Correction (QUAC) and Fast Line-of-sight Atmospheric Analysis of Spectral Hypercubes (FLAASH) tools are the most rigorous and accurate tools for reducing atmospheric effects and for correcting images to surface reflectance. These are model-based methods that require a separate license for the ENVI Atmospheric Correction module.

See the Atmospheric Correction topic to learn more about less rigorous tools that can yield acceptable results without requiring the ENVI Atmospheric Correction module. The Hyperspectral Analytics in ENVI whitepaper provides some guidance on choosing atmospheric correction tools in ENVI. This publication is available from the Harris Geospatial Solutions website.

Transform data to different spaces

See the Transforms topic for a list of tools for color sharpening, pan sharpening, and dimensionality expansion and reduction.

Principal components analysis (PCA) is a commonly used method for reducing the dimensionality of data in multispectral and super-spectral images. Use the Minimum Noise Fraction (MNF) tool with hyperspectral images. A more detailed discussion of MNF and PCA are provided in the Hyperspectral Analytics in ENVI whitepaper, available from the Harris Geospatial Solutions website.

Mask out unwanted features

You can use masks to exclude certain pixels from image processing or when computing image statistics. See the Masks topic for more information.

Create an image consisting of bands from different images

Use the Build Layer Stack tool to create a new file that consists of georeferenced images from different files or band groups (for example, Landsat-8 or Sentinel-2). Or, use the Build Band Stack tool when the input images are not georeferenced.

Create subsets of data

See the Subsets topic for instructions on cropping (chipping) specific geographic areas or only including certain spectral bands for subsequent analysis.

Smooth or sharpen images

The Display Tools topic provides details about applying smoothing and sharpening to images that are displayed in the current view. These enhancements are only temporary and do not persist when you close ENVI. To apply permanent smoothing and sharpening filters to images, use a combination of adaptive filters, convolution and morphology filters, frequency filters, and texture filters.

Create a mosaic of images

To mosaic georeferenced images into one image, the simplest option is to use the Quick Mosaic tool. To mosaic georeferenced images while also feathering their edges and balancing their colors, use the Seamless Mosaic workflow. Use the Pixel Based Mosaicking tool to create mosaics when the input images are not georeferenced.

Analyze Images

Classify an image into different land-use categories

Use the Classification workflow to categorize pixels in an image into different classes. This is the most efficient way to classify multispectral images.

Find more features "like this"

The ENVI Deep Learning module (available with a separate license and installation) can create highly accurate classification maps of specific features. using proven TensorFlow deep learning technology. You train a deep learning model to recognize those features using a set of labeled input images. Then you can apply the trained model to look for the same features in other, similar images. Documentation is available on our website or in the ENVI Help if you have the ENVI Deep Learning module installed on your system.

Extract features from images

The ENVI Feature Extraction module can be used to identify objects from panchromatic or multispectral imagery based on spatial, spectral, and texture characteristics. Then classify the objects into known feature types. Documentation is available in the ENVI Help.

Find specific materials in images

Use the Target Detection Wizard workflow to locate specific materials in images such as man-made structures, minerals, and vehicles. Reference spectra from a spectral library are used to locate targets and to separate them from background pixels.

To determine all of the different spectral materials that comprise an image, use the Spectral Hourglass Wizard or Linear Spectral Unmixing tools. With these tools, you derive "endmember" spectra directly from the image without relying on ancillary or reference spectra. These tools are commonly used for mineral mapping in hyperspectral images.

For more detail on these scenarios, refer to the Hyperspectral Analytics in ENVI whitepaper, available from the Harris Geospatial Solutions website.

Finally, use the Anomaly Detection workflow to find pixels that are spectrally distinct from the image background and whose composition is unknown. These pixels often represent objects that are "hiding" such as vehicles or structures that are not easily visible in a color or greyscale image.

Compare images from different dates

Use the Image Change workflow to identify the differences between two images of the same geographic extent, taken at different times. The images can be of any type such as RGB, multispectral, or panchromatic.

Or, use the Thematic Change tool to identify the differences between two classification images of the same extent over time.

Compare multiple images over time

See the Spatiotemporal Analysis topic for information on creating a time series of data when you have two or more images.

Study vegetation health

Use the Spectral Indices tool to assess the relative health of vegetation in images. Spectral indices are combinations of spectral reflectance from two or more wavelengths that indicate the relative abundance of features of interest. Vegetation indices are the most popular type, but other indices are available for burned areas, man-made (built-up) features, water, and geologic features.

ENVI also provides other vegetation analysis tools to identify areas of agricultural stress, fire fuel, and forest health.

The ENVI Crop Science module provides additional remote sensing analytics for precision agriculture and agronomy. This module requires a separate license and installation. Documentation is available on our website or in the ENVI Help if you have the ENVI Crop Science module installed on your system.

Analyze the shape of terrain

The Extract Topographic Features tool can classify each pixel in a DEM into morphometric features such as peaks, ridges, passes, planes, channels, and pits.

Use the Topographic Modeling tool to create shaded relief surfaces from DEM data and to extract parameters such as slope, aspect, and their derivatives.

For a quick view of terrain data, use the Topographic Shading Tool to blend a colored DEM with a shaded-relief image, slope image, aspect image, or derivatives of slope and aspect. The result is an image that provides a better visual representation of the shape and texture of topographic features than using the DEM alone.

Process point cloud data

Use the ENVI LiDAR application to process point cloud data and to extract features from them such as buildings, trees, and power lines.

Analyze SAR data

The ENVI SARscape module lets you process and analyze synthetic aperture radar (SAR) data and generate products like DEMs, interferometry, and surface deformation maps. This module requires a separate license and installation. ENVI SARscape documentation is provided by sarmap.

Get Mathematical Information From Images

Apply mathematical operations to image bands

Use the Band Math tool to apply a mathematical operation, IDL function, or custom function to one or more bands in an image.

The Band Ratios tool provides a quick way enhance the spectral differences between two bands.

Plot image data

Use the Scatter Plot Tool to classify two bands of image data. One band provides the x coordinates and the other band provides the y coordinates.

See the Profiles and Plots topic for information on plotting pixel data as lines called profiles. The most common type is a spectral profile, which shows the spectral reflectance or radiance curve of a given pixel. Spectral reflectance curves from hyperspectral images can be compared to spectral libraries or other pixels in the same image.

View image statistics

The Statistics topic provides information on viewing histograms and computing the mean, minimum, maximum, and standard devation of pixel values in an image.

Overlay Images on a Map

See the Map Information in ENVI topic to learn about the different spatial references used in ENVI. Use the following tools to georeference images to map projections:

Use the Reproject Raster tool to reproject georeferenced images to another projected coordinate system. You can also use this tool to convert from an RPC model, pseudo projection, or Geographic Lookup Table (GLT) to a standard Geographic Lat/Lon WGS-84 projection.

Finally, see Grid Definitions for more information about coregistering a time series of images or a layer stack of bands with different resolutions to a common spatial reference.

Create Presentations

See the Annotations topic for instructions on adding text, polylines and polygons, classification legends, color bars, and scale bars to image layers that are displayed in the current view. You can also add grid lines for geogreferenced images.

For elevation data, use the New Contour Layer menu option to display contour lines on single-band raster layers such as DEMs. This option provides a quick display of contour lines in the current view. Or use the Generate Contour Lines tool to create contour lines at full resolution and save them to a shapefile.

Use the Chip View to menu option to create screen captures of all layers displayed in the current view. The screen captures can be saved to ArcMap, Google Earth, Geospatial PDF, or PowerPoint. Any display enhancements, zooming, rotating, or Portals that are displayed in the view are burned into the output image.

The Export View to > Image File menu option exports all contents of a view to a red/green/blue (RGB) 24-bit image file. Even if a panchromatic image is displayed in the view, the output will have three bands (red, green, blue). The output image preserves any vector layers, annotation layers, feature counting layers, raster color slices, and image enhancements. It does not preserve any north arrows or cursor probe (crosshairs).

The Getting Started with ENVI tutorial demonstrates how to use many of these annotation and export options.

Perform Batch Processing with Data

use the ENVI Modeler to create custom workflows in ENVI and to run tools in batch mode. If you prefer programming, see the ENVI API Programming Guide to learn how to write API programs that extend and customize ENVI.

See Also


ENVI Tutorials, Supported Data Types, System Requirements



© 2020 Harris Geospatial Solutions, Inc. |  Legal
My Account    |    Store    |    Contact Us