258

ENVI 5.6 and IDL 8.8 are not compatible with MacOS 12 Monterey, but here’s a work-around

Apple released the newest iteration of MacOS, known as Monterey or MacOS 12, in October 2021. This version of MacOS is not officially supported by ENVI 5.6.x or IDL 8.8.x and there are known issues, mainly:

  • ENVI will not launch at all.
  • IDL graphics may fail to display, giving the following error output: 

     Error: Unresolved inheritance operation

These issues are related and work-arounds to them are described below. Administrator rights are required.

For a complete break-down of officially supported platforms for ENVI and IDL, see THIS page. 

 

RECOMMENDED WORK-AROUND:  Change the IDL launch script to include an updated definition for DYLD_LIBRARY_PATH.

1. Open the file /Applications/harris/envi56/idl88/bin/idl in a text editor. On most Mac systems, you will need to do so with elevated permissions if installed in the default location. This is most easily done through Apple Terminal with…

     sudo vi /Applications/harris/envi56/idl88/bin/idl

2. Find the line that reads “export DYLD_LIBRARY_PATH” near the bottom of the file and change it to the following:

     export DYLD_LIBRARY_PATH=/opt/X11/lib/flat_namespace:$DYLD_LIBRARY_PATH

3.  Save the file and exit the text editor. Both ENVI and IDL should now work normally.

NOTE: This work-around was tested with MacOS 12.0.1, ENVI+IDL 5.6.1, and XQuartz 2.8.1 on a system with an Intel CPU, but it is expected to work with ENVI 5.6.0 / IDL 8.8.0 and with Apple M1 chips as well.

 

ALTERNATIVE WORK-AROUND: Revert to an older version of ENVI or IDL. ENVI 5.5.3 and IDL 8.7.3 versions appear to work out-of-the-box on Monterey.

 

 

Written by BC(US) 11/12/2021, Reviewed by MM 11/12/2021

 

Please login or register to post comments.