6459

MacOS platform support for IDL

Update: February 20, 2020


macOS 10.15 (Catalina) is a supported platform under IDL 8.7.3 and ENVI 5.5.3 and does not require the patch mentioned below.

If you are installing IDL or ENVI on a macOS 10.17 operating system, or if you have IDL or ENVI installed on a previous macOS and are upgrading to 10.15, please refer to this Help Article before you begin the installation.

 

L3Harris remains committed to IDL on the macOS platform with the release of Catalina.

Previously, we had identified an issue that required a patch to earlier versions of IDL 8.7 (8.7 through 8.7.2) in order to run on this new macOS release. The issue was caused by the existing 32-bit applications used in IDL (AppleScripts and IDLSnapFileOpen). 32-bit applications are not supported under Catalina. This issue is resolved with IDL 8.7.3 (and ENVI 5.5.3).

We are also nearing completion of a substantial effort to update our internal DevOps cycle that we use to build, test, and release the IDL and ENVI software so the process is faster and more reliable. As part of this effort, we plan to address other outstanding concerns for IDL macOS such as a compatible Java version. This investment in our development process is important because L3Harris recognizes that IDL for macOS has been a popular platform, especially for users of Mac laptops. Look for these changes to be delivered in the next major release of IDL for macOS.

Please login or register to post comments.