131 Rate this article:
No rating

What's New in ENVI 5.6.1

ENVI 5.6.1 includes many performance improvements, new platform support, and new data access support.

For system requirements, see Platform Support for ENVI 5.6.1 and IDL 8.8.1.

New Features

This release includes many new and improved features.

Highlights

See the detailed sections that follow.

Supported Data Types

ENVI supports the following data types:

  • Analysis Ready Data (ARD) from DigitalGlobe / Maxar
  • PlanetScope PS2.SD and PSB.SD next-generation data
  • Pleiades-NEO
  • Sentinel-3 Level-2 aerosol optical depth (SL_2_AOD) from the Sea and Land Surface Temperature Radiometer (SLSTR)

Cloud Optimized GeoTIFF Support

The Open Remote Dataset dialog and ENVI::OpenRaster API routine can open Cloud Optimized GeoTIFF files from remote servers (HTTP) and Amazon Web Services (AWS) S3 buckets.

You can save images to Cloud Optimized GeoTIFF format. Use the File > Save As > Save As Cloud Optimized GeoTIFF menu option and select an output compression method.

OGC WFS and WMTS Support

The Remote Connection Manager and ENVI::OpenRaster API routine support the following Open Geospatial Consortium (OGC) datasets:

  • Web Feature Service (WFS)
  • Web Map Tile Service (WMTS)

Improved SkySat Support

Improvements were made to the way ENVI reads SkySat images and metadata. SkySat data support is now comprised of two parts:

  • Current products from Planet: Basic Scene, Video, Ortho Scene, Ortho Collect, and Analytic Collect. Use the File > Open menu option and select the associated *_metadata.json file.
  • Legacy Image Frames and Geo Imagery from Terra Bella / SkyBox Imaging (now owned by Planet). Use the File > Open As > Optical Sensors > Planet > SkySat Legacy menu option, and select the associated *_metadata.txt file to open any of these products.

Improved Landsat Support

ENVI now reads the following Collection 1 and 2 Landsat products distributed by the U.S. Geological Survey:

Data Type Menu Option File to Select
Landsat 1-8 Collection 2, Level 1, GeoTIFF with metadata

File > Open

File > Open As > Landsat > GeoTIFF with Metadata

*_MTL.txt
Landsat 4-8 Collection 2, Level 2, GeoTIFF with metadata File > Open *_MTL.txt
Landsat 4-8 Collection 1 Analysis Ready Data (ARD):
  • Surface Reflectance
  • Top of Atmosphere (TOA) Reflectance
  • TOA Angles
  • TOA Brightness Temperature
  • Provisional Surface Temperature
  • Quality Assessment
File > Open *.xml
Landsat 4-8 Collection 1, Level 3 products:
  • Burned Area
  • Dynamic Water Surface Extent
  • Fractional Snow Covered Area
File > Open *.xml

Multiple ARD product types (i.e., Surface Reflectance, TOA reflectance) from the same date and location can reside in the same directory, or in separate directories by product type. The same applies to Level 3 derived products. ENVI will group them into a single metaspectral dataset for quick access and display.

ENVI Servers

ENVI Servers work with Geospatial Services Framework (GSF) 3.0 in addition to 2.3.

The ENVI installer provides an option to install Geospatial Services Framework (GSF) if you will be running ENVI processes in the background, in parallel, or in a distributed environment. GSF is required for ENVI Server.

Application Startup Time

The ENVI user interface starts about 50% faster now. Headless instances of ENVI (where the user interface is displayed, typically in API code) start about 30% faster now.

Performance Increase for ENVI-Format Files

The read and write speed of ENVI-format raster files is dramatically faster, up to 90% in some cases. We implemented this feature based on user feedback that some ENVI-format files were too slow or could not be opened. With more efficient file access, you should notice a significant performance improvement for most image-processing tasks. The actual performance boost will depend on the algorithm and the interleave of the file on disk. Here are some notable increases in performance:

  • Some image classification algorithms are 60-80% faster; for example, Spectral Angle Mapper (SAM).
  • Creating a seamless mosaic of two hyperspectral images is about 80% faster.
  • QUick Atmospheric Correction (QUAC) is 20-40% faster, depending on the file interleave.
  • Linear spectral unmixing is 40-80% faster.

Macintosh M1 Support

Support for Macintosh M1 platforms has been added. A Rosetta 2 emulator is required.

NITF Updates

NITF and MIE4NITF files open about 80% faster now. Also, the display time for large NITF HSI BIP/BIL files is about 70% faster.

The new NITF Dataset Browser makes it easy to browse and display large NITF files with multiple image segments, as well as large MIE4NITF files with multiple series of image frames. You can view the contents of multiple files and view the metadata for selected files, segments, and series. The NITF Dataset Browser appears when you open a MIE4NITF dataset, or when you open a NITF file with more than one displayable image segment. You can also open it by clicking the "NITF Dataset Browser" button in the ENVI toolbar.

ENVI no longer displays annotation segments in NITF files. It does not output annotation segments when saving a NITF file to a new NITF file. A warning message will be issued if you open a NITF file that contains annotation segments, saying that ENVI will not use or save them. To use these segments in NITF files, use ENVI Classic.

Annotation Properties

The Fill Interior property and preference have a new Line option that fills polygons, rectangles, and circles with a series of lines. Customize the line pattern by setting the Fill OrientationFill Spacing, and/or Fill Crosshatch properties.

Tool Updates

The following tools were removed from the ENVI Toolbox. Many of these were carried over from ENVI Classic and have since been replaced with newer functionality.

  • Create Hill Shade Image: Use the Topographic Shading tool to create hillshade images.
  • Horizontal/Vertical Spectral Slice
  • Image-to-Image Registration: Use the Image Registration workflow.
  • Neural Net Classification: Use ENVI Deep Learning or the IDL Machine Learning routines.
  • New File Builder: Use the Build Band Stack tool.
  • Overlay Classes: You can already overlay multiple layers of data in ENVI, including classes.
  • Run ENVI Server Task (Run GSF Task): Use ENVI Server.
  • Subset Data from ROIs: Use File > Save As > ENVI, click the Spatial Subset button, then click the by ROI button.
  • View HDF Dataset/Global Attributes: Use the Dataset Browser to view HDF metadata.
  • Warp from GCPs: Image to Image Registration: Use the Image Registration workflow.

The Classification Image from ROIs tool was renamed to Convert ROIs to Classification.

The Lee Filter tool was split into three tools:

  • Lee Filter (Additive)
  • Lee Filter (Multiplicative)
  • Lee Filter (Additive-Multiplicative)

The Resize Data tool was replaced by a newer tool called Resize Raster. This tool lets you resample a raster to different dimensions by setting the output size, resizing factor, or pixel size.

The new Convert Feature Counts to ROI tool converts ENVI feature counts (.efc) to ROI files.

The Smooth VectorFilter VectorVector to Bounding Box, and Vector to Centroid tools have a new Units parameter. It lets you choose a different unit of measure (meters, feet, etc.) when specifying minimum and maximum vector areas and lengths.

Finally, 26 tools in the ENVI Toolbox were updated from their original ENVI Classic style to the newer ENVITask-based style, giving them a more modern appearance.

Esri Integration

ENVI supports the use of ArcGIS Online image layers.

Documentation

A new Sentinel-2 Time Series Analysis Tutorial is available. It demonstrates how to build a time series of Sentinel-2 multispectral images, using the ENVI Modeler. It explains how to view a time series profile and how to perform an ISODATA classification of NDVI values to study trends in crop health over a two-year period.

ENVI Help shortcuts are no longer available from the Windows Start menu. As always, access ENVI Help from the Help > Contents menu option in ENVI. If you have a license for ENVI+IDL, the IDL Help is also available from the ENVI Help table of contents, as well as help for ENVI modules that are installed (for example, Photogrammetry, Deep Learning and/or Crop Science).

The Landsat Time Series Tutorial was updated to use Analysis Ready Data (ARD) Surface Reflectance images, in ENVI raster format. The Las Vegas time series presented in the tutorial now spans 1985 through 2020.

A new ENVI Functional Summary topic summarizes all of the capabilities that the current version of ENVI provides.

Programming

Custom Plot Functions

You can now create custom ENVI plot functions in IDL. Plot functions provide a method for applying user-specified transforms to data in any ENVI plot window. You can choose a custom plot function from the Y: drop-down menu in any ENVI plot window.

Annotation API

Use the new ENVIAnnotationSet and ENVIAnnotationLayer routines to add annotations to the display. Use the ENVI::OpenAnnotation method to open annotation files (.anz) from disk.

NITF API

Use the new ENVINITF routine to work with complex NITF and MIE4NITF datasets.

Spatial Reference Methods

New ConvertFileToLonLat and ConvertLonLatToFile methods were added to the following spatial reference routines:

  • ENVIStandardRasterSpatialRef
  • ENVIRPCRasterSpatialRef
  • ENVIPseudoRasterSpatialRef
  • ENVINITFCSMRasterSpatialRef

RefreshWindow Method

Use the new ENVIUI::RefreshWindow method to refresh the ENVI display after it has changed but has not yet redrawn.

New Tasks

ExportRasterToCOG: Export a raster to Cloud Optimized GeoTIFF (COG) format.

Layer Manager and Toolbox Controls

The ENVIUI routine has two new keywords: LAYER_MANAGER_PANEL and TOOLBOX_PANEL. These control whether the panels are attached, detached, or collapsed in the application.