PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 28 Apr 2021 02:08 PM by  Ben Castellani
Mac X11 XQuartz 2.8.0 - IDL 8.5.1 incompatibility
 2 Replies
Sort:
You are not authorized to post a reply.
Author Messages


New Member


Posts:2
New Member


--
25 Feb 2021 12:31 AM
    i just moved to the new pre-release X11 2.8.0 for mac, and IDL crashes when you call dialog_pickfile().

    i'm using 8.5.1, which i know is not the current version, so i will look into a newer version. but maybe someone else can test this with more recent versions to make sure it's not a common issue?

    X11 2.8.0 has some other good fixes, like faster pasting text onto the command line after a graphics window is open. that was always very slow on 2.7.11.

    the dialog_pickfile() incompatibility exists with both the beta3 and the rc1 releases of XQuartz 2.8.0.


    New Member


    Posts:2
    New Member


    --
    26 Feb 2021 12:27 PM
    the fix for this is now listed on the XQuartz GitHub issues page:

     


    it is the same issue that was identified for IDL 8.5.1 and XQuartz 2.7.10:

    [CODE]https://www.l3harrisgeospatial.com/Support/Self-Help-Tools/Help-Articles/Help-Articles-Detail/ArtMID/10220/ArticleID/15188/XQuartz-2710-is-Not-Compatible-with-ENVI-531-and-IDL-851


    New Member


    Posts:60
    New Member


    --
    28 Apr 2021 02:08 PM
    The latest version of XQuartz that we know worked with IDL 8.5.1 was XQuartz 2.7.9. It is recommended that you downgrade to that version.
    IDL 8.6+ versions should be compatible with newer XQuartz versions.

    At the time of this post in April 2021, IDL 8.8 is the current version and it is confirmed to work with XQuartz 2.8.0 just fine.
    You are not authorized to post a reply.