PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 08 Oct 2020 08:58 AM by  Jason Wolfe
FeatureExtraction Workflow problem
 3 Replies
Sort:
You are not authorized to post a reply.
Author Messages

Jennifer Swenson



New Member


Posts:3
New Member


--
24 Sep 2020 02:32 PM
    Hi, we discovered that after running the classification in the workflow, if you go back to alter your segments (or change attributes), the Next button is grayed out/non selectable. also classes cannot be saved at this point. So, you have to start from scratch. is there any way around this? it seems going back and forth would be part of a 'workflow' and would improve the final classification. (ENVI 5.5.3).

    Jason Wolfe



    New Member


    Posts:57
    New Member


    --
    30 Sep 2020 08:01 AM
    Hi, what step are you on when you try to go back and modify the segments or change attributes? I assume you're using the rule-based classification workflow. After setting up classes and rules and proceeding to the Export step, you can definitely click the Back button to modify your settings. But once you click Finish, then yes, the workflow is dismissed and you would have to start over again to define new segments and rules.

    Jennifer Swenson



    New Member


    Posts:3
    New Member


    --
    01 Oct 2020 02:15 PM
    Hi, this is in the example based workflow- once a classification is actually run- you can go back to the previous step (Tabs: "Examples Selection", "attribute Selection", "Algorithms")-- but from there we cannot save the classes or move ahead and run the classification again. The same thing happens if close out and restore the classes from a previous session. The next button is grayed out.

    Jason Wolfe



    New Member


    Posts:57
    New Member


    --
    08 Oct 2020 08:58 AM
    Hi, I'm sorry for the delayed response. I tried the example-based workflow with some fake classes but was unable to reproduce this issue. When I ran the classification and backed up to the "Choose Examples" step, I was able to modify my classes and parameters, and save my classes. The Next button wasn't grayed out for me. I have asked others to test it as well. In the mean time, could you indicate what operating system you are on (Windows, Linux, Mac) and whether or not you see this behavior when following our Fx tutorial?

    https://www.harrisgeospatial.com/portals/0/pdfs/envi/FXExampleBasedTutorial.pdf
    You are not authorized to post a reply.