PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 03 Sep 2020 02:37 PM by  Reda Amer
PSinSAR processing issue
 8 Replies
Sort:
You are not authorized to post a reply.
Author Messages

Corsabrin



New Member


Posts:27
New Member


--
23 May 2016 09:32 PM
    Hi guys, I am trying to process 8 images from S1A for PSinSAR in sarscape. I understand at least 20 images is recommended. In my test, during the First Inversion step, the processing is stuck at: 'preliminary candidates selection' for quite some time. I have been waiting at this step for about 24 hours. Anyone has any idea what is going on? Do I continue waiting or is there already a processing error? Or is it because I need to use > 20 SLCs? For your information, the preliminary candidates selection shows: 244/567, where i believe 567 is the total number of PS points. The number increases slowly to 244, but never goes all the way to 567. It just stucks there. Changing the coherence threshold is the same, i will end up at 531/1147, where the first number ends up getting 'stuck'. Would really appreciate your advice! Thank you in advance and have a good day. Regards Chad

    Peg Shippert



    Basic Member


    Posts:228
    Basic Member


    --
    13 Jun 2016 10:13 AM
    Persistent Scatterer processing can take a very long time, and I've seen it often take longer than a day to complete. In my experience, if a problem is encountered, usually SARscape will bring up an error message. When it seems that nothing is happening, usually SARscape is just performing some very intense calculation. On a Windows system, you can check to see whether the process is still running, versus hung, by bringing up the Windows Task Manager, and looking at the Processes tab. If you sort by CPU, you may find that the main_persistent_scatterer.exe process is taking up a lot of CPU resources. That will mean that SARscape is still processing. If that process is not taking any CPU resources, then something has probably happened to stop the processing. In that case, and if you did not get any error message from SARscape, you might want to look in the IDL Workbench to see if any error has been printed to the IDL Console. That may help you understand why the processing stopped. You can also choose (from the ENVI Toolbox) SARscape > Administration > Save Error Report to force SARscape to save information its state. If you sent the Error Report file to your local distributor or to Harris Geospatial Tech Support (support@harris.com), that may help us figure out what kind of problem you might bne running into. Regards, Peg

    Corsabrin



    New Member


    Posts:27
    New Member


    --
    28 Jun 2016 09:09 AM
    Hi Peg Thank you for the clarification. I am currently running the First Inversion step in PSinSAR and it is currently stuck at: preliminary candidates searching 1434/4088. I have been running this for close to 3 days. I looked into the Processes and sorted by CPU. main_persistent_scatterers.exe is constantly taking up about 14.2% of my CPU, it fluctuates between 13.8 to 14.9%. Based on this, I am assuming that SARScape is still running the process. Number of SLCs are 21 images. I will let it continue to run, perhaps up to a week and hopefully by then the processing will complete. Will update if it is done Regards Chad

    Clémence Dubois



    New Member


    Posts:1
    New Member


    --
    04 Jul 2016 02:39 AM
    Hi Chad, I'm encountering the same problem as you do/did. I'm processing 26 interferogramms of S1A and it gets stuck at 386/546 during the first inversion step. I'm curious to know if something changed for you in the last few days? Does SARscape yet displays something else? It seems to me that the SubAreas are not created, and I'm wondering if it could be due to a DEM problem. Indeed, I performed the same processing before, using GEO-GLOBAL coordinates, and it did work (processing time ~ 1,5day). However, I had some issue with the created SubArea grid and couln't display it above my results. So I changed GEO-GLOBAL to UTM-GLOBAl coordinates for the DEM Import, and now it is stuck. I would be grateful for any answer that could bring me further! Regards, Clémence

    Peg Shippert



    Basic Member


    Posts:228
    Basic Member


    --
    05 Jul 2016 11:31 AM
    Hi Clemence, In some older versions of SARscape, there was an issue with the Sample Selection step at the beginning of the processing chain. It sounds like you might be using that tool to identify a subarea in your datasets to use when processing your stack. If you are on a version of SARscape that has this problem, then what you will want to do is create a subset of your whole stack first, then start the processing chain for the interferometric stacking. You would use the tool found in the ENVI Toolbox under SARscape > General Tools > Sample Selection > Sample Selection SAR Geometry Data to make your subset of your stack. I hope that helps. Peg

    Corsabrin



    New Member


    Posts:27
    New Member


    --
    07 Jul 2016 03:28 AM
    Hi Peg Actually I have tried to use the sample selection tool as you have mentioned (currently on SARScape 5.2), still the problems persists. I wonder if there are any specific parameter changes that I should invoke to make the First Inversion step (preliminary candidates) be successful?

    Peg Shippert



    Basic Member


    Posts:228
    Basic Member


    --
    12 Jul 2016 10:07 AM
    There may be some parameter settings that would help. It might be easiest if you submit this question directly to Harris Geospatial tech support (support@harris.com or (303) 413-3920) or your local distributor. It might be easier to track down the issue if you can send screen shots of parameters, and perhaps share data, etc. which can't be done in this forum - Peg

    Shivendra Singh



    New Member


    Posts:1
    New Member


    --
    14 Jan 2019 12:42 AM
    I am also facing the same problem of PS Analysis: First Inversion "preliminary candidates searching". Its stuck at 808/1131. I took 30 S1A images cropped to required area. It took 3 days for Interferometric Process. My CPU usage is only 6.3% for main_persistent_scatterers.exe. Anything that can help...please suggest.

    Regards

    Reda Amer



    New Member


    Posts:1
    New Member


    --
    03 Sep 2020 02:37 PM
    Peg,
    I am processing a 32 image sentinel stack. I waited 7 days for the PS first inversion, it stuck at Candidates Searching [1/286], and my CPU about 6.5%. I think there is a problem with SARScape inversion. I contacted the Harris support but no response :(
    I hope Harris could help us to solve this issue.
    You are not authorized to post a reply.